PopUp experiencing performance issues

Incident Report for OrderMyGear

Resolved

This incident has been resolved.
Posted May 23, 2025 - 11:20 CDT

Update

We are continuing to monitor for any further issues.
Posted May 23, 2025 - 10:49 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 23, 2025 - 10:47 CDT

Investigating

We are currently investigating this issue.
Posted May 23, 2025 - 10:40 CDT
This incident affected: Popup Stores (Popup Stores API, Popup Stores Storefronts).