AWS cloud provider incident

Incident Report for OrderMyGear

Resolved

This incident has been resolved and all OrderMyGear services are operating normally.
Posted Oct 21, 2025 - 10:39 CDT

Update

AWS has stated that its outage is resolved. OrderMyGear services should now be operational. Engineering will continue to monitor for any new issues.
Posted Oct 20, 2025 - 18:48 CDT

Update

We are observing issues related to the AWS outage and continue to monitor for any further issues.
Posted Oct 20, 2025 - 11:08 CDT

Monitoring

AWS is experiencing a widespread incident that has impacted services across the internet, like OrderMyGear's DistributorCentral. The OrderMyGear Engineering team is aware of this issue and is closely monitoring status updates from its cloud provider, AWS, as they work towards mitigation and resolution.

Additional updates will be provided as needed.
Posted Oct 20, 2025 - 06:44 CDT
This incident affected: OneSource (OneSource API) and Popup Stores (Popup Stores Products).